Audi TT Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Hi,

I have just had a run in my TT roadster, a late DSG 2054 V6 model with 35k on clock and the ESP light came on and has stayed on, no other warnings.

Any ideas what could cause this? The ESP switch on the dash doesn't seem to alter it's state.

Thanks Mark
 

·
Premium Member
Joined
·
6,342 Posts
It could be one of many faults, Vagcom scan will have to be done to identify the issue.
 

·
Registered
Joined
·
240 Posts
i will be at exhausts uk on friday from 12 till whenever they finish (downpipe and cat) so can plug you in and see if you want,or you can come over to worksop,i dont have vag com but do have a very good vag reader :)
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #6 ·
marknjayne said:
i will be at exhausts uk on friday from 12 till whenever they finish (downpipe and cat) so can plug you in and see if you want,or you can come over to worksop,i dont have vag com but do have a very good vag reader :)
Where about is this?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
marknjayne said:
hhliam said:
marknjayne said:
i will be at exhausts uk on friday from 12 till whenever they finish (downpipe and cat) so can plug you in and see if you want,or you can come over to worksop,i dont have vag com but do have a very good vag reader :)
Where about is this?
here buddy
I am only 10 minutes away, how much does it cost?

Thanks
 

·
Registered
Joined
·
240 Posts
hhliam said:
marknjayne said:
hhliam said:
I am only 10 minutes away, how much does it cost?

Thanks
what for mate,for me to plug you in?....free its a 2 min job :)
Very kind of you. i can get there around 1-2.
Cheers Mark
ok mate,will pm you my number,would have thought it would take around 2 hrs for them to make up and fit the exhaust so should be there till around 2-2.30 pm :)
 

·
Registered
Joined
·
13,044 Posts
Good luck with the scan. I hope it's just spurious.

It really could be anything,
faulty/dirty MAF,
dirty G200 (clockspring) steering wheel sensor,
ABS ECU or Brake pressure sensors may have died,
or it may just need a brake fluid change (see forum entries about clutch/brake work)

Or if you're really lucky it may just be that you did a wheel-spin that confused the ESP/ABS sensor (it takes a few mins/ign recycle to clear) and it won't come back.

As with all (ECU) faults, note it and clear it with VCDS (VagCom) but wait for it to return and even then don't spend any money until you've confirmed it.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #16 ·
Skeee said:
Good luck with the scan. I hope it's just spurious.

It really could be anything,
faulty/dirty MAF,
dirty G200 (clockspring) steering wheel sensor,
ABS ECU or Brake pressure sensors may have died,
or it may just need a brake fluid change (see forum entries about clutch/brake work)

Or if you're really lucky it may just be that you did a wheel-spin that confused the ESP/ABS sensor (it takes a few mins/ign recycle to clear) and it won't come back.

As with all (ECU) faults, note it and clear it with VCDS (VagCom) but wait for it to return and even then don't spend any money until you've confirmed it.
It came on as i put my foot down to overtake some one, and stayed on
 

·
Registered
Joined
·
240 Posts
hhliam said:
Skeee said:
Good luck with the scan. I hope it's just spurious.

It really could be anything,
faulty/dirty MAF,
dirty G200 (clockspring) steering wheel sensor,
ABS ECU or Brake pressure sensors may have died,
or it may just need a brake fluid change (see forum entries about clutch/brake work)

Or if you're really lucky it may just be that you did a wheel-spin that confused the ESP/ABS sensor (it takes a few mins/ign recycle to clear) and it won't come back.

As with all (ECU) faults, note it and clear it with VCDS (VagCom) but wait for it to return and even then don't spend any money until you've confirmed it.
It came on as i put my foot down to overtake some one, and stayed on
we will plug in and see what it is,clear it for you and hope its just a one off ,if the light comes back on then at least you will know what the issue is,if it stays off...bonus
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #18 ·
Thanks to Mark [ marknjayne ] for checking my car with is VAG reader, the alarm had cleared by the time i met him. It stated that it was a brake switch problem?

The ESP light keeps appearing if i put my down but clears after i restart car.
 

·
Registered
Joined
·
240 Posts
hhliam said:
Thanks to Mark [ marknjayne ] for checking my car with is VAG reader, the alarm had cleared by the time i met him. It stated that it was a brake switch problem?

The ESP light keeps appearing if i put my down but clears after i restart car.
Does the same happen when the ESP button is pressed (turned off ) or just when the ESP is on
 

·
Registered
Joined
·
13,044 Posts
Sorry, I forgot to add the 'Brake Pedal Switch' to the list.
It only costs about a tenner and is easy to change. Refitting the lower dash tray is a bit fiddly but there are instructions somewhere on the forum.

If you can find someone nearby with a VagCom lead there is a test for the brake switch.
Select:-
Control Module- Engine- Measuring Blocks- Block 66-

Then as you press the Clutch/Brake Pedals, the first/second two digits change from 0-1 respectively.

Just noticed it's a DSG- so ignore first digit!
 
1 - 20 of 20 Posts
Top