Audi TT Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3,368 Posts
Discussion Starter · #1 ·
Hi guys,

I bought a 1.5Tb Iomega external drive 2 weeks ago & have backed up about 600Gb of stuff to it. Today it just started clicking when I switched it on & it isn't appearing on my Mac's desktop & on further investigation via Google it appears that it might be knackered.

Obviously I am not a very happy bunny as it is less than a month old, expensive & made by a reputable manufacturer - whilst the data on it isn't critical, it would be a complete pain in the proverbial to lose it.

On some of the tech sites I visited they talked about the freezer trick, which is exactly as it sounds. You wrap the drive in plastic freezer bags & let it freeze overnight - the thinking behind it is that the metal will contract when cold & expand when hot & hopefully 'reset' the reader arm. I don't want to pay for expensive data recovery as it is personal files rather than business stuff, so has anyone tried this fix - if so did it work?

TIA.

Mart.
 

·
Administrator
2001 Amulet Red 225 coupe.Owned from new as well as a Nurburg VXR & an XR3, all from new.
Joined
·
97,179 Posts
Hi, Does it have an external power supply. If not I have found that sometimes the USB port does not always supply enough volts & it just clicks. Its not consistent though, one day it will work without additional power, another day it doesn't.
Hoggy. :D
 

·
Registered
Joined
·
3,368 Posts
Discussion Starter · #4 ·
Yeah, it has an external power supply. A friend of mine suggested that it might be that - sadly I have just tried a different PSU & it does exactly the same thing :(
 

·
Registered
Joined
·
10,498 Posts
If it's only few months old it should be covered under the manufacturer warranty. Give them a bell and arrange the exchange of the drive and the (free) transfer of your data.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top