Audi TT Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello I’m new to the forum – and I have a mark one TT roadster and the roof refuses to close- It has a replacement pump and realise but still won’t work opens okay but will not close-are there some relays elsewhere that I need to be looking at and also is there a mobile TT expert in my area I live on the Northants stroke but border for any help/advice would be greatly appreciated
Trevor
 

·
Administrator
2001 Amulet Red 225 coupe.Owned from new as well as a Nurburg VXR & an XR3, all from new.
Joined
·
97,209 Posts
Hi Trevor, Welcome to the TTF.
I will move your post into the MK1 section, you should get more replies.
Hoggy. :)
 

·
Registered
Joined
·
3,357 Posts
There are two relays, one for "open" and the other for "close". They are mounted on the pump, and are the same as each other, standard 5-pin relays. An easy way to see if it's the relay is to exchange them and see if the problem moves, but decent relays aren't expensive so it might be easiest to just put two new ones in.

ETA - Ah, I see you probably meant "it has had a brand new pump and relays" - in which case the above doesn't help. I can't delete it, though.

Does it do anything at all to try to close? If it tries but the roof doesn't move far enough, that might point to it needing to be filled with the appropriate fluid.
 

·
Registered
Joined
·
12,715 Posts
If it does need fluid, it uses the same stuff as the power steering:
CHF202 which is a green synthetic CHF fluid.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
If it does need fluid, it uses the same stuff as the power steering:
CHF202 which is a green synthetic CHF fluid.
Many thanks for that – it does open alright and the pump and the relays on the pump are working okay – I believe there might be some other relay or control That may be the problem but don’t know where to look
 

·
Registered
Joined
·
212 Posts
I had a faulty relay replaced that and it worked in both directions see if you can swap them around and se if your problem swaps to the other open / close side of the problem you already have if it does it’s the relay
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
I had a faulty relay replaced that and it worked in both directions see if you can swap them around and se if your problem swaps to the other open / close side of the problem you already have if it does it’s the relay
I had a faulty relay replaced that and it worked in both directions see if you can swap them around and se if your problem swaps to the other open / close side of the problem you already have if it does it’s the relay
Many thanks-problem solved-it was corrosion due to a leak from rear window on the terminals. To comfort control unit next to motor
Grateful for your response
 
1 - 10 of 10 Posts
Top