Audi TT Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
Guys,

Yesterday I fitted a Forge Splitr dumpvalve, and removed it because I didn't like it, so put my standard re-circ back on straight away.

I then this morning installed my new Pipercross panel filter to my standard, undrilled airbox.

What I notice now is more of an audible turbo sucking sound when accelerating, and somehow can also hear what I can only assume is turbo flutter / chattering at lower speeds when lifting off.

My car wasn't doing this before fitting the panel filter, but obviously nor was it doing it before the dumpvalve faff around either.

Any ideas?
 

·
Registered
Joined
·
1,002 Posts
Fragmau5 said:
Guys,

Yesterday I fitted a Forge Splitr dumpvalve, and removed it because I didn't like it, so put my standard re-circ back on straight away.

I then this morning installed my new Pipercross panel filter to my standard, undrilled airbox.

What I notice now is more of an audible turbo sucking sound when accelerating, and somehow can also hear what I can only assume is turbo flutter / chattering at lower speeds when lifting off.

My car wasn't doing this before fitting the panel filter, but obviously nor was it doing it before the dumpvalve faff around either.

Any ideas?
I was the same as you and asked the same question on here when I fitted my induction kit and the answer was "yes its normal".
Las week when I had my clutch changed at Midland VW I asked them to give my car the once over and they said they found no problems,so I can only assume the answer I got on here was correct.

I too am also bet happy with the extra noise now ;)
 

·
Registered
Joined
·
13,492 Posts
You will tend to find recirculating valves that use the form of a diaphragm, will always make more noise than a piston type like say a forge 007 or 08. And through an open induction you will hear clearer all of this going on. I think after the splitter valve you forgot about the noise you were accustomed to with the standard n75 valve. :) Its all part of the fun of a turbo car. You should have heard my ur quattro's.... :p Or even the audi team rally quattros in the 80's belting through the uk forests in the rac rally. I was lucky my dad took me down to watch when i was a lad. awesome memories. No fluke i ended up a total audi nut. Thanks Dad. :p

Damien.
 

·
Registered
Joined
·
3,833 Posts
Fragmau5 said:
Guys,

Yesterday I fitted a Forge Splitr dumpvalve, and removed it because I didn't like it, so put my standard re-circ back on straight away.

I then this morning installed my new Pipercross panel filter to my standard, undrilled airbox.

What I notice now is more of an audible turbo sucking sound when accelerating, and somehow can also hear what I can only assume is turbo flutter / chattering at lower speeds when lifting off.

My car wasn't doing this before fitting the panel filter, but obviously nor was it doing it before the dumpvalve faff around either.

Any ideas?
could be a shot standard DV??? Nafe P's did exactly the same......
 

·
Registered
Joined
·
13,492 Posts
RudeBadger said:
Fragmau5 said:
Guys,

Yesterday I fitted a Forge Splitr dumpvalve, and removed it because I didn't like it, so put my standard re-circ back on straight away.

I then this morning installed my new Pipercross panel filter to my standard, undrilled airbox.

What I notice now is more of an audible turbo sucking sound when accelerating, and somehow can also hear what I can only assume is turbo flutter / chattering at lower speeds when lifting off.

My car wasn't doing this before fitting the panel filter, but obviously nor was it doing it before the dumpvalve faff around either.

Any ideas?
could be a shot standard DV??? Nafe P's did exactly the same......
If so i have a standard new n75 you can borrow. A broken n75 tends to honk when its buggered.
Damien.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #7 ·
Cheers for the replies guys.

A few of you have mentioned about sounds from the open induction, but I only put in a panel filter into the standard airbox.

Anyway, after a bit of faffing around, I decided to remove the standard recirc and try the forge splitR again, but this time with the trumpet removed and the bung screwed in, so it was in recirc mode. I also took the filter out and refitted it just to make sure there were no leaks etc.

Verdict: there is more turbo noise still, must be from the change in filter - but from what I can tell, my power is still the same, so I don't think there is a boost leak. As for the flutter I was getting from refitting the standard recirc, the new forge recirc has eliminated that, so I can only assume I might have broken the standard recirc when removing it somehow? Either way, I'm quite pleased :)

Next stop, REMAP. Think I'll have to travel down to AmD for that as don't think there are many reputable audi mappers up here in the north east.
 

·
Registered
Joined
·
416 Posts
after i fitter my 008 im thinking i have a boost leak. it kicks in after 3k on hard accel. could someone help?? or am i been para lol
 
1 - 8 of 8 Posts
Top