Audi TT Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
691 Posts
Discussion Starter · #1 ·
Just returned to work today and when i got in the car noticed the electro mechanical power steering light is very very pale yellow. Not lit buy looks like its drawn in crayon if that makes sense. As i drove to work it went even paler but can just be seen. when i turn off it goes a little brighter for a second then goes back to just visible. The car has stood for a week so im wondering is it damp or could the battery be a little low? Its the original and 5 yrs old , also i used the tyre pump to blow a flat tyre up while it was stood.

If i disconnect the battery to charge it will i loose the radio or anything?
 

·
Registered
Joined
·
120 Posts
Mine has just developed exactly the same thing! Again my car hasn't been used much lately. Power steering itself works absolutely fine - be very interested to hear of how to fix this feint light.
 

·
Registered
Joined
·
120 Posts
Just put mine on charge. Took charge for 30 seconds then battery charger read fully charged, so doubt problem there. No difference to light. By the way you don't need to disconnect battery to charge, just use terminals under bonnet.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #4 ·
I have checked the battery and its 12.4 v then 14.3 when running so im doubting that. Im now wondering if its an earthing issue. I have noticed that it changes intensity if i push the radio button or interior light. Wonder if theres a dashboard earth fault. I have obd2 read it and no faults are stored. Funnily enough today at lunch when i checked it the light wasnt on and it was a nice dry blowy day. Just wonder if damp isnt helping. Also i had my haldex oil done the day i broke up before xmas so has the plug been disturbed however would that upset the power steering circuit?

Oddly though the only time it was driven over the holiday the radio display didnt work for the first 10 mins.
My next port of call is going to be a hairdryer behind the dash to make sure its not damp and a whiff of wd40 around the electrical plugs underneath.

The thing i find odd is that its visible when the cars locked on the drive with no key in it!
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #5 ·
Update

Just been in touch with someone who repairs these units and apparently is very common on 2009 models.
Firstly theres an issue with the 2009 cluster and secondly the wiring can easily be corroded and led's are a very easy route to earth.
Apparently Audi say its just a feature that occurs. The trouble is getting to the plug on the rack, must be an undertray off job.
 

·
Registered
Joined
·
120 Posts
Very interesting. Used mine today and seemed to go out (very feint) but when parked again could see it gently pulsing, feint then slightly darker. Mine is December 2010 TDI model and is going in for first Haldex change this month. I planned to ask them re. light when it goes in.

I have also had radio failure once or twice until car been going 10 mins. I have Audi satnav unit. Actually, the satnav CD wouldn't read though the media player worked OK. Opened the satnav (electrical hinged door) which then proceeded to stay open ignoring button to close. After a while button worked OK and could close the unit. Hasn't done that for a couple of months but it did follow period of car not being used.

If we don't resolve I will certainly update you with my garage verdict when I get it (independent Audi/VW specialist). Thanks for information and like to hear anymore you can find out on this.
 

·
Premium Member
Joined
·
14,025 Posts
If steering is fine then it's low voltage related
Either way try this
Start the car
Turn wheel full lock left, hold for several seconds then turn full lock right, hold for several seconds, return steering to centre and drive straight for 30 yards
This resets / calibrates the steering angle sensor which is what the light is related too
See if the light stays off

Worth a try guys

On iPhone using Tapacrap
 

·
Registered
Joined
·
120 Posts
Thanks for idea retro. Did try it but no difference to the light.

OK mine going in Tuesday. My independent dealer also said common problem with TT's and possible replacement of a unit in the dash.

Let you know outcome shortly.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #9 ·
im interested in how you get on with the dealer, mine has all but gone now just a very slight outline. makes me thing either the battery was slightly discharged or it is just a damp thing thats sorting itself. However i only have 6 weeks warranty left so in really keen to know how you get on.
 

·
Registered
Joined
·
120 Posts
Will do.
Today mine is also very feint - can only really see it when it gets dark. I have one month left on my warranty also. Dealer was saying it's so common he isn't sure warranty will cover it as it's a "known problem". Can't imagine how it's not going to cover it as it's not my fault it's common and wasn't like that when I bought the car 11 months ago!
Let you know end of Tuesday...
 

·
Premium Member
Joined
·
118 Posts
An interesting thing to note...my battery went flat - very flat.
I have charged it up and its all good again, first time I started the car - power steering light was on.
I re-calibrated using the instructions above and the light went out straight away so jobs a good un.

Just thought I'd mention it as there does seem to be a correlation between dead battery and power steering.

Mind you, I also lost all my settings such as stereo, coming home lights, RCL one press open and who knows what else.
 

·
Registered
Joined
·
120 Posts
It's not good news. Audi independent specialist says it needs a replacement instrument panel pod which costs £528 plus VAT. They first have to disconnect the power steering and test for a wiring fault but they tell me, it's always been new instrument panel required in previous cases. They say it's possible to get old unit removed and sent away for repair but future failures are then likely and car will be off road for duration.

So with two hours labour at £66 per hour plus VAT (I'm down south where Audi charge £160 plus VAT per hour!) it totals £792.

I think any warning lights showing is automatic MOT failure so it's not going to be easy to live with it as it is. Going to try on my warranty though dealer says they may or may not accept the claim.
 

·
Registered
Joined
·
691 Posts
Discussion Starter · #13 ·
mine has all but gone out, however theres a place on the bay that repair them for £150 so if it blows its going there.
 

·
Registered
Joined
·
10,872 Posts
How nice... Audi still can't get electronics under control, yet they are experimenting with self driving cars.....

Faulty earth points are often the cause of electric troubles. See the rear light topic too.
 

·
Registered
Joined
·
4,015 Posts
Mine has had this recently. Well started a couple of months ago intermittently but I only use it about once a week at the moment - Extremely faint amber power steering light, mostly only visible driving at night and away from street lights, but brighter when starting the car after it's been sat so I thought it might be battery but no issues turning over. Drives perfectly too so didn't think it was actually anything to do with power steering.

Tried resetting angle sensor as suggested by ReTTro, still there. Tried cranking the blowers and all lights on thinking it might be earth related, no change. I noticed the light seemed to flicker, especially when going over uneven road or bumps so figured there might be a corroded connection. But then also noticed the light stays on after they key has been taken out, and flickers, some times the light is on as soon as the door has been opened, so no ignition.

Took this video at night after a 30 min drive.


This pic is after just after restarting, engine running just handbrake on

Speedometer Vehicle Car Odometer Trip computer


So of the opinion that this is the above cluster issue, I've taken it to my local vehicle electrical specialist, whose confirmed my suspicions and sent the cluster off for repair. Will update on the outcome and cost when it's sorted.

Cheers
Ash
 
1 - 18 of 18 Posts
Top