Audi TT Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi this is my first post in this forum so apologies if I’ve rambled on.

I’ve recently purchased my TTS through a private sale, everything seemed fine to begin with, no clutch slipping or anything like that. It’s got an R-tech stage 2+ remap with a 3” downpipe and sports cat but stock exhaust. It has an upgraded hpfp, intercooler kit, induction kit and the upgraded clutch.

3 days after purchasing the car, the intercooler hose popped off and I was able to put it back on and haven’t had a problem since. (Don’t think that’s relevant but included just incase)

Now, 5 days into owning the car the clutch has gone. No warning signs, very sudden, got the awful clutch smell alongside so I knew that’s what it was. It wouldn’t drive at all when it was warm but now it’s cooled down it can move slightly but not enough to drive properly.

so this leads to my question; the owner before me had upgraded the clutch in 2018 to the helix organic clutch kit with dmf. Since then the car has only driven less than 20,000 miles. Do you think it has something to do with a dodgy remap? Or has it just been driven stupidly to cause the clutch to wear so quickly? Or is there some other underlying issue that I could take into consideration?

Either way I’m getting the clutch replaced on it ASAP and wondering which clutch to go for. I was debating getting another helix but I’m worried after this experience. I’ve read the sachs clutch is equally as good? What would people recommend?

Thank you in advance :)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Probably just been hooned too hard. I'm open to being corrected but I've never heard of a clutch going from an engine tune.
Thanks for your quick reply, yeah I’m leaning towards that being the cause unfortunately.. I’m fairly new to modified cars so thought I would check and see if I’m missing anything
 

·
Registered
2008 TTS
Joined
·
1,616 Posts
As already stated - R-tech is the place to take an EA113 TFSI, so certainly isn't a dodgy map

I have personally run a helix organic on stock DMF in my 2+ Rtech mapped TTS for 4+ years & 40k+ miles
As you will see in start of link below, doesn't get baby'd, seen track time and gets used properly every time it goes out.
TTS review


Torque figure it mapped to, should be within quoted spec of the Helix - what does the graph show
Realistically need to take the current clutch out - no way of knowing without seeing that first to have an idea of the actual fault

Once there, would be well worth checking that it hasn't been caused by gearbox output shaft play or crank walk of the engine
Has it got a 'push clutch to start' delete? Or you do you still have to push it?
If that's the case I would certainly be looking into it being crank walk first

Replacement clutch wise would steer clear of sachs, they don't do well on EA113 for some reason, always reports of issue with high rev gear changes
Helix either organic or possibly go for the paddle friction disc, but realistically no way to say until the current clutch is out
 
1 - 6 of 6 Posts
Top