Audi TT Forum banner
1 - 20 of 40 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
Hi,
Got some serious problems with the RS since yesterday. The boost has decreased, the exhausts seem louder and it looks like it's smoking under acceleration.
What would be the first checks I can make to try and diagnose what's wrong? I have a diagnostics tool so I'll try that and report back.
Will need to go into Audi as it's still got a couple months warranty remaining.
Any help appreciated
Thanks
 

·
Registered
Joined
·
3,575 Posts
A friend of mine on his 1,500 miles old ttrs has just had the turbo replaced. Apparently the turbine inside the turbo was catching on the actual cast housing! I'm hearing more turbo issues on the ttrs than any other 2.0tfsi engines at the moment. Makes you wonder...
 

·
Registered
Joined
·
13,237 Posts
andyleem said:
Only error it's showing its 'Switch for tensioning strut stowed'.
Must be a roadster then.

Do you check your oil level regularly? If so, check it now and if the level has gone down markedly this MAY help to point to turbo seals.
What colour is the smoke on acceleration? Burnt oil will be blue/white. Black smoke will be unburnt fuel.

All academic really since you still have warranty: it's worth calling Audi Assist who may be able to advise whether or not to drive the car further, then book it into your dealer.
 

·
Registered
Joined
·
2,174 Posts
andyleem said:
Had an oil service about 4 months ago, haven't checked since. Just checked now and it's below minimum. :-|
I would be sure to top it up before taking it to the dealer, in case they say "your fault for not maintaining oil level".
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #10 ·
Ok so the boost seems like it's reletively OK, despite pretty much cutting out for most of last night. What is still very evident is the exhaust is louder/deeper, even with sport mode OFF. Slight smell of oil too.

Oil has been topped up with Castrol now.

Are Audi good at sorting out problems like this under warranty?
 

·
Registered
Joined
·
1,162 Posts
You have warranty, just bring it to your dealer, they will sort it out for you...
 

·
Registered
Joined
·
8,416 Posts
McKenzie said:
A friend of mine on his 1,500 miles old ttrs has just had the turbo replaced. Apparently the turbine inside the turbo was catching on the actual cast housing! I'm hearing more turbo issues on the ttrs than any other 2.0tfsi engines at the moment. Makes you wonder...
Have you heard of many RS turbo problems? I read everything on here and a few other forums and I have to say it's not something that I've thought -"Oh, ANOTHER RS turbo gone!" if you know what I mean. Not like s-tronic gearboxes or window regulators.
 

·
Registered
Joined
·
3,575 Posts
wja96 said:
McKenzie said:
A friend of mine on his 1,500 miles old ttrs has just had the turbo replaced. Apparently the turbine inside the turbo was catching on the actual cast housing! I'm hearing more turbo issues on the ttrs than any other 2.0tfsi engines at the moment. Makes you wonder...
Have you heard of many RS turbo problems? I read everything on here and a few other forums and I have to say it's not something that I've thought -"Oh, ANOTHER RS turbo gone!" if you know what I mean. Not like s-tronic gearboxes or window regulators.
It's not something that is happening into the tens of times but have heard of a few turbo's being replaced over various forums on the TTRS and RS3. probably only 3-4 now but quite surprising considering the age of the car. I very rarely hear of K04 turbo problems and hear of the odd high mileage K03 going wrong. I'm just a little curious to why the RS turbo has had a few problems considering that they can handle 410+BHP and are relatively new engines with low mileage. These things do happen and probably more of a coincidence rather than a common occurrence. Still, I wouldn't say no to a RS or RS3 engine instead of my 2.0tfsi :D
 
1 - 20 of 40 Posts
Top