Audi TT Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
806 Posts
Discussion Starter · #1 ·
Took my car in for an Engine oil & Haldex service. My local Audi dealer couldn't fit the work in so I took the car to a local, and very well regarded Audi specialist.

When I collected my car I instantly noticed that the usual "Start-up double pop" was missing. As I drove out of the complex I stopped at the junction and the stop start kicked in. The car was still in dynamic and my car, as per the user manual, has never before engaged start stop in dynamic! As I left the junction there was a clear absence of RS noise and I then noted the full fat sports exhaust was also turned off and I was in D mode not S mode!

I cycled through the drive select mode and eventually everything came back, but having now taken the car for a drive I have noticed that there are a LOT more, unwelcome changes.

I am aware through threads on this forum and the FB group that there are two updates that could cause changes to the exhaust and drive select. I have called the place that has undertaken the work and they are adamant that they have not updated anything.
 

·
Registered
Joined
·
806 Posts
Discussion Starter · #2 ·
ECU update (30E3) is to reduce the exhaust sound/noise by changing the exhaust valve opening pattern.
When the update is operative, the flaps will be
  • closed in comfort (in D and neither in S)
  • closed in Auto (D)
  • open in individual, but only if "engine sound" is set in dynamic
  • closed at each engine start, doesn't matter in which mode you are
Also, the RS typical "bang" at engine start is drastically reduced (probably because the flaps are closed)
This seems to relate to some of the changes I have noticed. The start up is a shadow of what I've had since I bought the car and upshifts now sound like a damp fart rather than the "CRACK & BANG" I had before.
 

·
Registered
Joined
·
2,679 Posts
bad news for you :cry:, my friend….
I believe they updated your ECU with that (in)famous 30E3 sw version… :mad:
also, it came out recently that Audi stopped that sw update since it doesn't work as they expected..
a new, updated sw version (006?) will be released in the future with the same aim (noise reduction trough exhaust flaps different behaviour)
I guess the only way to recover the old good sound (=flaps original pattern) is to go to Audi and ask (or better, pretend) for an ECU sw roll-back, explaining them that you know Audi stopped the 30E3 recall for admitted problems...
 

·
Registered
Joined
·
2,679 Posts
here the official letter Audi Gerrmany sent to a TT-RS owner, announcing the 30E3 market treatment is not effective and therefore definitively stopped
Font Parallel Screenshot Number Document
 

·
Registered
Joined
·
806 Posts
Discussion Starter · #6 ·
Thanks Kevin, I just can't understand how this has got onto my car at a non franchised Audi specialist :confused:

Would the 30E3 have also affected the DRIVE SELECT too? I understand that I could get the exhaust working again by purchasing the CETE module but I can't be doing with the car slipping out of my selected mode every time I stop the flipping car.
 

·
Registered
Joined
·
2,679 Posts
I think the 30E3 sw doesn't alter the drive select per sè, just the way the flaps work according to the different driving modes… in other words, nothing changes apart the flaps pattern...

the fact that a non-franchised garage has been able to update the sw sounds strange to me too :unsure:
however, can't you confirm with them, what they really did?
 

·
Registered
Joined
·
806 Posts
Discussion Starter · #8 ·
I have followed the conversations on drive select and it has been odd to see how some RS's seem to function as mine used to, selected mode remaining selected. And some function as mine now does, defaulting to comfort mode and switching on stop / start, despite it still saying Dynamic in the VC!

I fully get the stop / start feature in towns and cities, to cut local pollution. But over 90% of my driving takes place in rural areas. When you approach a junction, ready to pull out and merge with fast moving traffic, the engine turning off is bordering on dangerous.
 

·
Registered
Joined
·
806 Posts
Discussion Starter · #9 ·
OK, the place where I took my car have assured me that no update was performed. All they did was re-set the service indicator. Does the car have a post service GENTLE mode enabled?

Now here is the strange bit - this morning the car started - AS NORMAL! I still have that weird car being in Comfort Mode, despite being set and displaying it is in Dynamic. So I cycled the mode - dynamic engaged and I went out, slowly warming the car and all was as it used to be, car burbling along nicely. Once warmed up everything worked exactly as it should - S mode holding onto gears and not behaving like D mode and trying to get into 7th gear! So there I was, happy that I have most of my car back to how it was when it did something really odd. As I slowed into one of the villages the upshifts were accompanied by something my car has never done, a little bit like THIS :rolleyes:
 

·
Registered
Joined
·
53 Posts
Sorry for potentially asking a dumb question…
But can you use VCDS or OBDEleven and see what kind of firmware are you running on your ECU or Engine module?
Just so you can be sure if anyone installed anything at all?
 

·
Registered
Joined
·
202 Posts
Is there a valve control module already installed ? Is it a used car ?
 

·
Registered
Joined
·
2,679 Posts
sure!
in the below image, ECU HD and SW versions (sw version is 004)
Font Line Pattern Parallel Rectangle




Sorry for potentially asking a dumb question…
But can you use VCDS or OBDEleven and see what kind of firmware are you running on your ECU or Engine module?
Just so you can be sure if anyone installed anything at all?
 

·
Registered
Joined
·
53 Posts
sure!
in the below image, ECU HD and SW versions (sw version is 004)
View attachment 486491
So OP can maybe borrow diagnostic tool and see if for a fact someone installed that dreaded 30E3 firmware?
I would do it just so I can know to avoid that garage in the future as flashing anything like that with out owners consent or knowledge...is not a good idea. :)
 

·
Registered
Joined
·
2,679 Posts
yes, the 30E3 is linked to the 005 sw version, and as said, the VCDS can read the sw version

So OP can maybe borrow diagnostic tool and see if for a fact someone installed that dreaded 30E3 firmware?
I would do it just so I can know to avoid that garage in the future as flashing anything like that with out owners consent or knowledge...is not a good idea. :)
 
1 - 20 of 23 Posts
Top